moyashidaisuke's diary

フリーランスのエンジニアのダイスケです。プログラム関連とかギター関連とか旅行関連とか色々。

alpineでsharpのインストールでエラー

このブログのローカル環境のDockerを再ビルドしたら、gatsby-plugin-sharpで必要なライブラリのインストールでエラーが発生するようになった。

tep 4/6 : RUN apk add vips-dev fftw-dev build-base --update-cache     --repository https://alpine.global.ssl.fastly.net/alpine/edge/testing/     --repository https://alpine.global.ssl.fastly.net/alpine/edge/main
 ---> Running in a89fc9c7788a
fetch https://alpine.global.ssl.fastly.net/alpine/edge/main/x86_64/APKINDEX.tar.gz
fetch https://alpine.global.ssl.fastly.net/alpine/edge/testing/x86_64/APKINDEX.tar.gz
ERROR: unsatisfiable constraints:
  vips-dev (missing):
    required by: world[vips-dev]
ERROR: Service 'node' failed to build: The command '/bin/sh -c apk add vips-dev fftw-dev build-base --update-cache     --repository https://alpine.global.ssl.fastly.net/alpine/edge/testing/     --repository https://alpine.global.ssl.fastly.net/alpine/edge/main' returned a non-zero code: 1

対応策はこちら。

github.com

github.com

repositoryのURLを変更したら無事に通りました。